Image: Jekyll 3.0.1リリース

Jekyll News

サイト生成ツールJekyll バージョン3.0.1(2015/11/17)リリース。Incremental regeneration実装。ただ、ベータ版とは違い、標準では無効になっているようだ。–incrementalスイッチを付けるかconfig.ymlにincremental: trueを書き加えるとIncremental regenerationが有効になる。サイトのプレビューとブラッシュアップはこれでらくらく。

この際、highlighterもpygmentsを辞めてrougeに切り替えることにした。rougeが知らぬ間にPowerShellスクリプトに対応してた。Winバッチコマンドは対応していないみたいだけど、構文が複雑・読みにくくなることはあまりないし、頻繁に使うものでもないし、まあいいや。pygmentsを使わなくなったからPythonも不要になるというのは大きい。

パフォーマンスが大幅向上したというが、正直よくわからん。

依存コンポーネントが減ったと言うことなので、一からJekyllをセットアップしてみる。

Ruby Installer for Windows 2.1.7をインストール。Development Kitも必要。Jekyll導入のコマンドはこんな感じで。

C:\RubyDevKit>ruby dk.rb init
[INFO] found RubyInstaller v2.1.7 at C:/Ruby21-x64

Initialization complete! Please review and modify the auto-generated
'config.yml' file to ensure it contains the root directories to all
of the installed Rubies you want enhanced by the DevKit.

C:\RubyDevKit>ruby dk.rb install
[INFO] Updating convenience notice gem override for 'C:/Ruby21-x64'
[INFO] Installing 'C:/Ruby21-x64/lib/ruby/site_ruby/devkit.rb'

C:\RubyDevKit>gem install jekyll
Fetching: liquid-3.0.6.gem (100%)
Successfully installed liquid-3.0.6
Fetching: kramdown-1.9.0.gem (100%)
Successfully installed kramdown-1.9.0
Fetching: mercenary-0.3.5.gem (100%)
Successfully installed mercenary-0.3.5
Fetching: safe_yaml-1.0.4.gem (100%)
Successfully installed safe_yaml-1.0.4
Fetching: colorator-0.1.gem (100%)
Successfully installed colorator-0.1
Fetching: rouge-1.10.1.gem (100%)
Successfully installed rouge-1.10.1
Fetching: sass-3.4.19.gem (100%)
Successfully installed sass-3.4.19
Fetching: jekyll-sass-converter-1.3.0.gem (100%)
Successfully installed jekyll-sass-converter-1.3.0
Fetching: ffi-1.9.10-x64-mingw32.gem (100%)
Successfully installed ffi-1.9.10-x64-mingw32
Fetching: rb-inotify-0.9.5.gem (100%)
Successfully installed rb-inotify-0.9.5
Fetching: rb-fsevent-0.9.6.gem (100%)
Successfully installed rb-fsevent-0.9.6
Fetching: listen-3.0.5.gem (100%)
Successfully installed listen-3.0.5
Fetching: jekyll-watch-1.3.0.gem (100%)
Successfully installed jekyll-watch-1.3.0
Fetching: jekyll-3.0.1.gem (100%)
Successfully installed jekyll-3.0.1
Parsing documentation for colorator-0.1
Installing ri documentation for colorator-0.1
Parsing documentation for ffi-1.9.10-x64-mingw32
Installing ri documentation for ffi-1.9.10-x64-mingw32
Parsing documentation for jekyll-3.0.1
Installing ri documentation for jekyll-3.0.1
Parsing documentation for jekyll-sass-converter-1.3.0
Installing ri documentation for jekyll-sass-converter-1.3.0
Parsing documentation for jekyll-watch-1.3.0
Installing ri documentation for jekyll-watch-1.3.0
Parsing documentation for kramdown-1.9.0
Installing ri documentation for kramdown-1.9.0
Parsing documentation for liquid-3.0.6
Installing ri documentation for liquid-3.0.6
Parsing documentation for listen-3.0.5
Installing ri documentation for listen-3.0.5
Parsing documentation for mercenary-0.3.5
Installing ri documentation for mercenary-0.3.5
Parsing documentation for rb-fsevent-0.9.6
Installing ri documentation for rb-fsevent-0.9.6
Parsing documentation for rb-inotify-0.9.5
Installing ri documentation for rb-inotify-0.9.5
Parsing documentation for rouge-1.10.1
Installing ri documentation for rouge-1.10.1
Parsing documentation for safe_yaml-1.0.4
Installing ri documentation for safe_yaml-1.0.4
Parsing documentation for sass-3.4.19
Installing ri documentation for sass-3.4.19
Done installing documentation for colorator, ffi, jekyll, jekyll-sass-converter, jekyll-watch, kramdown, liquid, listen, mercenary, rb-fsevent, rb-inotify, rouge, safe_yaml, sass after 16 seconds
14 gems installed

C:\RubyDevKit>gem install jekyll-paginate
Fetching: jekyll-paginate-1.1.0.gem (100%)
Successfully installed jekyll-paginate-1.1.0
Parsing documentation for jekyll-paginate-1.1.0
Installing ri documentation for jekyll-paginate-1.1.0
Done installing documentation for jekyll-paginate after 0 seconds
1 gem installed

C:\RubyDevKit>gem install wdm
Fetching: wdm-0.1.1.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
Successfully installed wdm-0.1.1
Parsing documentation for wdm-0.1.1
Installing ri documentation for wdm-0.1.1
Done installing documentation for wdm after 0 seconds
1 gem installed

C:\RubyDevKit>

jekyll-pagenateとwdmの追加導入が必要だった。jekyllを含む計16個のgemをインストールした。


comments powered by Disqus

※コメント欄が表示されない場合はdisqusについてJavascriptが有効であることを確認して下さい.