Image: Haswellマシン(i5-4690+Z97)でWindows Meを動かしてみた

Windows 10とWindows 95でデュアルブートを組んだという猛者に感化されて、私もHaswellマシンにWindows Meを突っ込んでみました。実用性は考えていません。ただの余興みたいなものです。本当は「最新PCでWindows Meを動かしてみた」としたかったんだけど、さすがにたった1世代の差で買い替えるような余裕は持っていないので。

リスペクト→ Windows95とWindows Insider Previewをデュアルブート - Yahoo!知恵袋

なぜWin98じゃないのかというとWinMe以上に厄介事が増えるからです。USB-HDD非対応、2.2GHz以上のCPUでは起動しないなど。

用意したもの

パーツ構成

現在のメイン機を流用。この記事を書いている今はもう戻しました。でないと困る。

  • CPU: Intel Core i5-4690 3.5GHz (Haswell Refresh, LGA1150) - やっぱK付きが良かったかなと思うこの頃。まあ中古だけど。
  • MB: ASRock Z97 Extreme4 (Intel Z97) - このMBはPCIスロットがないのでレガシー用途には不向き
  • MEM: Patriot PSD38G1600KH (DDR3-1600 4GBx2)
  • HDD: 東芝 MK1676GSX (2.5” SATA 160GB) - PS3からの抜き出し品
  • ODD: Pioneer BDR-208XJBK (BD-XL) - トレイの防音ゴムが張り付いてイジェクトが上手くいかないことがしばしば。
  • VGA: Leadtek WinFast PX7600 GT TDH (GeForce 7600 GT PCI-Express) - 当時のLeadtekの栄光は今や見る影もない
  • PSU: FSP AU-400 (400W 80PLUS GOLD) - 3年以上酷使しているがノートラブル。
  • USB_KBD: FILCO Majestouch NINJA (USBキーボード) - 環境に因らずリセット時にたまに操作不能になる使えない奴
  • USB_MOUSE: Logicool G502(カーソルが暴走して使い物にならない) → Logicool G300rで正常動作

グラボだけは古いパーツを使わざるを得なかった。LAN、サウンドも必要ならば古いパーツを用意しなければいけないかも。

その他物品

  • Windows 98 通常パッケージ
  • Windows Me アップグレードパッケージ
  • Transcend製USBメモリ 4GB 型番不明

ダウンロード入手したソフト

セットアップの下準備

Win98起動ディスクから作ったイメージファイルにFDSKを入れ、それをRufusでDDイメージとしてUSBメモリに書き込む。マザボのUEFIセットアップでAHCIをIDE互換モードに変更。ちなみにCDドライバは標準のoakcdrom.sysでは認識できなかったので、FreeDOS用として配布されているgcdrom.sysを使用。

Image: WinMe Setup

USBブートで起動ディスクを起動。まりも氏作のFDSKでハードディスクの管理テーブルを初期化、IO.SYS用MBR書き込み、FAT32基本パーティション作成。パーティションのサイズは64GBを超えると厄介なこと(SCANDISKバグ)に巻き込まれるので60000MBとした。

Image: WinMe Setup

Windows Me インストール

Windows MeのCDからsetup.exe /isを実行。最初のセットアップ画面が出てひとまずホッとするのもつかの間。マウスカーソルが暴走して使い物にならない。まあキーボードだけでも何とかするさ。(セットアップ完了後Logicool G300に交換してあっさり解決)

Image: WinMe Setup

インストール処理が始まり、最初の再起動後に起動にこけて、再起動を何度も繰り返すようになる。1GB超のメモリを積んだWin98/Me環境で起きる有名なバグだ。起動ディスクのEDITコマンドを使い、インストール先WindowsフォルダーのSystem.iniファイルを編集。386EnhセクションにMaxPhysPage=40000を追加。

Image: WinMe Setup

本来ならすごい時間が掛かったりフリーズしたりする、Win9x/Meセットアップの難所の一つ、プラグアンドプレイ認識。それがなぜか一瞬で終わる。(後にそれが異常なことだと分かるのだが)

Image: WinMe Setup

2回目の再起動後。順調順調。

Image: WinMe Setup

WinMeセットアップ完了。デスクトップが表示された!でも、何か物足りない。嫌な予感しかしない。

Image: WinMe Setup

デバイスの認識状況は?デバイスマネージャーを見てみよう。

Image: WinMe Setup

えっ?あれぇ(゜ロ゜) 何でこんなすっからかんなんだ。ACPI BIOS・PCIバス配下にたくさんぶら下がってくるはずのものがない。

レジストリエディターでHKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows \CurrentVersion \ Detectを参照。DWORD値でACPIOption、値を1に設定。コントロールパネルのハードウェアの追加で自動認識で進めるとACPI BIOSが追加される。

Image: WinMe Setup

ACPI BIOSを無事に追加できたぞ。ん?「Plug and Play BIOS (fail safe)」って何だ。調べるに、どうもこのドライバを「PCIバス」に更新するとうまくいくらしい。PCIバスに更新して再起動。

Image: WinMe Setup

おお~これこれ!初回起動時にこれが出ないから違和感付きまとっていたんだ。PCIブリッジのドライバは自動インストールに任せる。サウンドドライバ、ネットワーク、グラボ、USBは不明なデバイスとして残る。再起動する。

Image: WinMe Setup

え?どうもIDEインターフェイスがうまく動作していないらしい。なら仕方ないということでキーを押すと。。。

Image: WinMe Setup

おーい!結局ドライブはMS-DOS互換モードでのアクセスになった。まあ、CPU周りの性能が良いからかそんなに遅い気はしないけど。

Image: WinMe Setup

ここでようやく零地点に到達したよ。ドライバの導入作業はここから。

ドライバの導入結果

  • IDE I/F: MS-DOS互換モードでの動作。
  • グラボ: 非公式ドライバ(Unofficial NVIDIA Display Driver 82.69)を導入。なぜかインストーラーが起動しなかったのでinfでインストールした。1920x1080出力では暗転する。1680x900では正常に表示。dxdiagのDirect3DのテストとCrystalMark09のOpenGLベンチマークは完走した。
  • オンボードサウンド: RealtekのサイトからWin2000/XP用のWDMドライバーが使えそうだと思って試したけど、インストーラーもInfもあたらなかった。HD AudioのWin98/Me用ドライバはないはずだから、これが無理なら諦めるしか無さそう。
  • オンボードLAN: Win2000用ドライバはない。XPのドライバは試していない。
  • USB: 非公式のUSB2.0ドライバで動作。USBキーボード、USBマウス、USBメモリともに使用できた。ちなみにUSBドライバの転送はFreeDOSブータブルなUSBメモリでブートしてCOPYコマンドでコピーした。
  • MON: モニター情報・カラープロファイルのドライバは型がWin98から変わっていないので、最新ディスプレイのドライバも大体当たるはず。ASUS PB278QRのドライバは当たった。

あくまで一時的な実験なので安定性は見ていない。

後でトップのスクリーンショットを見て気付きましたが、CDドライブが認識されていませんね。Windowsのconfig.sysにgcdrom.sysを組み込めば認識されるのかな。USB外付けのCDドライブって使えたっけ。

参考資料

問題解決の参考になった資料。感謝!


comments powered by Disqus

※コメント欄が表示されない場合はdisqusについてJavascriptが有効であることを確認して下さい.

(C) 2008-2017 akm. This blog theme is based on sakmug. Hosted by Xdomain